Issue with centering data

First of all - thanks for developing Shapeworks. It looks like a great piece of software that will be very useful in many fields.

After having gone through the examples, I started playing around with my own data (MRI data of muscles) in Shapeworks Studio. Following the ‘ellipsoid’ example, I placed a set of binary masks in a folder and adjusted the Excel-file to the corresponding filenames. I managed to open the data in Shapeworks Studio but got stuck in the Grooming phase when rigidly aligning my shapes. If I select the option ‘Center’ I end up without any results: no groomed shapes are generated and the distance maps are empty. I’m thinking it might have something to do with the header information in my NDDR files, but the files open in the correct coordinate system in other software (e.g. ITK-SNAP).
Any ideas on how to resolve this issue?

Thanks in advance.

Hi Bart,

Have you tried using the default parameters. After the grooming step, the visualization is typically expecting distance transforms. I would recommend having anti aliasing and fast marching (distance transform) on as well. Let us know if the defaults work.

Also, sometimes the camera could be off, there is a reset camera button on the lower left of the viewers.


Yes, I tried with the default settings at first and after some trial and error I figured out it’s the “Center” option that resulted in empty distance transforms. So the distance transforms are made (nrrd files), but upon inspection in ITK-SNAP I found out the entire image is 0. Without centering the shapes I do get distance transforms as expected (and visualisations in Shapeworks), but they are not aligned which may lead to the error I get in the next step (trying to sample outside of narrow band).


Do you think you might be able to share a couple of your data files with us so that we could take a look?

Hi Alan

Here is some data in which the issue with centering occurred. This is what I did in Shapeworks Studio:

  • Open Project → select example.xlsx. The segmentation for the five shapes show up (ungroomed) as expected.
  • In the tab Groom, I left all the default settings as is and press Run Groom. Distance maps are created (segmentation1.nii_DT.nrrd, etc.), but no shapes are visible (also after resetting the view). I opened the distance maps in ITK-SNAP and noticed that all voxels have value -1.7e38.
  • If I don’t Center the data by unchecking the Center checkbox and run grooming again, the groomed shapes show up and the distance maps look as expected (positive inside the segmentation, negative outside).
  • When I try to run the step Optimize with the non-centered shapes, I get the error “Attempt to sample at a point outside the narrow band”. Consider increasing the narrow band.

I am using Shapeworks 6.0.0-RC9.

Any help would be greatly appreciated!

Thanks, Bart

(Attachment is missing)

Oh, I realized that I can’t attach data in the forum. I have emailed you some data.
Thanks, Bart

Thanks Bart,

Ok, I see the problem. The orientation of this data is different than what ShapeWorks is expecting. This will be fixed in the upcoming 6.0 release. Until then, you can change the orientation of your data using a tool such as Convert3D:

For example:

c3d file.nii.gz -orient RAI -o file_RAI.nii.gz

1 Like

Thanks! That resolved the issue!